Resolved
Degraded Email Performance
Started 15 Apr at 07:53pm UTC, resolved 18 Apr at 09:38pm UTC.
Resolved
While our standard email services are fully operational, we have made the decision to pause our Global Group Redistribution services (email redirects) while we transition to a more reliable solution.
Updated
We are currently in a wait-and-see phase regarding our email redirects. While our internal tests confirm that our new records are correctly configured, our external routing service is currently unable to "see" these updates.
Created
While our email infrastructure is online, we are currently tracking significant delivery latency and reports of intermittent message failures across our distribution groups.
We are treating this as a high-priority issue and are working to restore real-time delivery as quickly as possible.