Back
Degraded

Degraded / Under Research

Started 18 Apr at 09:57pm UTC, last updated 5 May at 06:14pm UTC.

Direct-Mail Services (Core) Global Group Redistribution
Updated

The planned server upgrade has been postponed and will be rescheduled for a later date. In the meantime, we are shifting our focus to a more immediate solution for our mailing services.

Key Changes:

  • DMS Status: Direct-Mail Services (DMS) are currently being taken offline.

  • GGR Activation: we are switching back to Global Group Redistribution (GGR) to handle our mail traffic.

  • Address Consolidation: All email addresses that previously used a subdomain are being moved to the root domain (placed before the @ symbol). This centralizes our communication and simplifies the configuration.

Posted 5 May at 06:14pm UTC.
Updated

We have finalized our plan to migrate to a higher-capacity environment to host our new integrated mail server. However, our provider currently has this specific hardware tier listed as out of stock.

As soon as the upgrade is applied, we will schedule a maintenance window to deploy the mailing server and resolve all current conflicts.

Posted 2 May at 11:20am UTC.
Updated

After extensive research, our team is moving forward with a potential solution to modernize our email infrastructure. We are currently evaluating the implementation to replace our current setup.

Posted 29 Apr at 12:32pm UTC.
Updated

We have spent the latest session deep-diving into the ongoing email issues. At this stage, we have not yet made the expected breakthrough, and the root cause remains under active investigation.

Posted 29 Apr at 09:46am UTC.
Updated

We are officially beginning a deep-dive investigation into our email infrastructure to resolve the ongoing routing and delivery issues.

Posted 28 Apr at 07:32pm UTC.
Updated

We haven't yet reached a resolution for the ongoing email routing issues. As a solo project, balancing infrastructure updates with active troubleshooting takes time, and we have decided to dedicate the coming days to finding either a robust temporary workaround or a permanent fix.

Posted 28 Apr at 06:29am UTC.
Updated

Until our next update, please refrain from sending messages to any "Global" or Group addresses. Any attempts to use these addresses will result in an immediate "Error" or "Undeliverable" return message.

Posted 19 Apr at 03:59am UTC.
Updated

We have temporarily suspended testing on the Global Group Redistribution (GGR) service. Investigation into the routing conflicts will resume at the start of our next scheduled working session.

Posted 18 Apr at 10:28pm UTC.
Created

While our Direct-Mail Services are stable, the GGR layer is currently undergoing a deep-dive investigation. We have isolated the issue to the complex "one-to-many" routing logic required to distribute messages across our global groups.

Posted 18 Apr at 09:57pm UTC.